YHD-101S noob wanting to use internal slicer


#21

Thanks, but I’m getting an error message: "Couldn’t determine model of projector on port:/dev/ttyUSB0 " and I can’t even recover my previous settings. This is a bit of a disaster because now my printer is unusable whatever I do, and I have no idea how to get it back into working order.


#22

Hi danilius

Could you try to re-enable the wanhao D7 profile? And than go to printer list and click Edit, you will see this dialog box :

Please change the bottom 2 to Select a serial port since I think you might have something else ;)!

That should sort the "Couldn’t determine model of projector on port:/dev/ttyUSB0 " issue

(/Display0 should be 0.0 at your machine)


#23

The available options for both ports are:
/dev/ttyAMA0
/dev/ttyUSB0
First available Serial Port
Autodetect 3D printer firmware
Autodetect projector
GCode response simulation

Which one goes for which?

Also, do the checkboxes next to those last two options need to be ticked? If so, what should the settings be?

I tried fiddling around, but got the following message:
"Couldn’t determine model of projector on port:/dev/ttyAMA0 "


#24

Tried Auto detect for the motor and projector and got:
"Couldn’t determine model of projector on port:/dev/ttyUSB0 "


#25

can you maybe post a screenshot here?


#26


#27


#28

can you post a screenshot with the options out?


#29

I don’t have my original printer listed here.


#30


#31

I downloaded the printer config before doing all this, is there any way of recovering that so at least I can get my printer up and running in the meanwhile?


#32

can you set it like this? This works for me on the pi


#33

I don’t have the Full Screen Mode option. Does it matter?


#34

Tried that, but the motor does not work.

Is there any way of recovering the factory-installed settings?


#35

OK, got it working now with CW files. So, phew, I’m back in action.

However, with uploaded STL files the platform homes OK at the start of the job, but then does not move the platform up and does not peel.

Here is the gcode for lifting:
M106 S0 ;Disale LED array
G1 Z(${ZLiftDist} * ${ZDir}) F{${CURSLICE} < $ZNumLiftFirstLayers?$ZLiftBtmRate:${ZLiftRate}}
G1 Z((${LayerThickness}-${ZLiftDist}) * ${ZDir}) F$ZRetractRate
; %d$BlankTime
M106 S255 ;Enable LED array


#36

Try my settings for header and lift . See my post above.


#37

kafka, thanks, but you are printing files with CW, which I have working fine now. What I want to do is print files using the Photonic3D embedded slicer, without using CW. That’s what got me into this trouble in the first place, and what I’m aiming to get my printer to do. Print without having to use CW.


#38

No problem. I would like to avoid using CW too. It takes way too long to slice and a long time to upload to Photonic3d. Waste of time. FlashPrint has better supports and slices on the fly but too bad we can not import it to Photonic3d.
I do not want to drop Photonic3D for Nanodlp.
I wish Wes can allow or finds the solution to be able to support other formats like SLC, SVGX, or even we be able to copy and paste slice Gcode into Photonic3D.


#39

From what I understand, it’s supposed to work out of the box. It’s probably some minor issue, and I would love to help out tracking it down.


#40

Thanks Danilius, you mean Photonic3D or CW?
If so which files should I explore? To let you know I have zero programming background, but can manage.