Projector List

Hello,

Can anyone give me a list of the best projectors that can be used to make a DLP printer?

THANKS!

:slight_smile:

Here are the manuals for four projectors that we autodetect out of the box with zero setup:


https://github.com/area515/Creation-Workshop-Host/files/129785/RS232_codes.pdf
https://github.com/area515/Creation-Workshop-Host/files/88303/RS232_Control_Codes_H6510BD.pdf

Can I find a lamp to use ultraviolet light with these projectors ?

Thanks

As I mentioned in the above post, these projectors work unmodified with Photonic3d. Just plug the serial cable into the raspberry pi(if you want to control them with Photonic) and plug the power cord into the wall. I use this projector: RS232_Control_Codes_H6510BD.

I think Photonic3D software is really nice. I have a mUVe style printer, and as one poster noted in a previous post, this software does not seem to work with professional UV LED HDMI light engines.

The original Creation Workshop does. With Photonic I get an error to the effect that it cannot identify my light source.

All the homing and stepper controls and CW file uploading works just fine. LED light engines are a no go at this time it seems.

The work you need to do is probably outside of Photonic3D, at the Linux and XOrg level to ensure that the light engine is properly detected at the OS level as a monitor with the correct resolution and refresh rate.

Similar to the setup in the Displays control panel on Windows, you’ll have to work on the configs at the Linux level in order to get the projector working as a second display prior to beginning work with Photonic3D. This is pretty much similar to the way that Creation Workshop works, which will just blind project to whatever is configured as the second monitor, the only difference here is that you need to work at the Linux level, which your vendor may not have provided out of the box settings for and would thus need to figure out yourself.

Just as CW will work with any projector that can be detected as a second monitor on Windows, Photonic3D will work with any projector that can be detected as a second monitor on the system you are using to print, which could be Windows, Linux, or MacOS depending on where you are running it.

Thanks for your reply jkao!
I understand what you are saying. However, when I try the PC version, it also does not work. The Photonic3D software picks up both displays…however when display 0 is selected, it projects to the monitor…when display 1 is selected, it does not show anything.

Not sure what the issue would be in this case. CW works just fine on PC with LED light engine HDMI. Same issue on the PC as on Linux.

This is an example of what I am trying to use…
http://www.ti.com/devnet/docs/catalog/endequipmentproductfolder.tsp?actionPerformed=productFolder&productId=23621

In your original post you mentioned that Photonic didn’t identity your light source, I assume you’ve fixed that problem given that you are now able to choose the second display. If that’s the case, then there really isn’t any reason it shouldn’t work.

Before we try looking much further I’d like to understand what you are seeing as the Photonic3d takes exclusive use of the screen. Let’s first start in Wiindows since you already have the projector working there. First make sure that CW is shutdown, then describe what is on the second display before you start Photonic(It should be a second Windows desktop.) Now after starting Photonic3d(assuming you’ve configured the printer to autostart) the second display should flicker once or twice and turn completely black. If Photonic3d isn’t configured to autostart, you’ll need to start the printer that is configured with your second display. Again, the display should flicker and turn black.

Let me know what happens, and we’ll take the next step.

On Windows:
Display 0 projects windows desktop.
Display 1 is blank. It will not project the calibration grid or anything else.

I can switch windows to project to the LED engine…without a problem (desktop icons in UV of course). I can toggle windows to choose either the UV (second monitor) or default display or extend across both. In other words, windows is recognizing the second display and sends images to it.

Photonic does not project onto the second display even though I can select it as an option.

Those are exactly the details I wanted to understand when Windows takes control of the screen. Thanks. However, our next step is to specifically understand what happens when Photonic3d takes exclusive use of the screen. For example it might:

  1. Do absolutely nothing and keep showing the Windows Desktop. (Bad)
  2. Flicker the screen a couple of times and eventually settle back on the Windows Desktop while the printer stays started. (bad)
  3. Flicker the screen a couple of times and eventually settle back on the Windows Desktop and your printer will not start. (Not great news)
  4. The display flickers black and stays black and the printer stays started. (Probably good news)

Then, when you shut down your printer manually it should go right back to the Windows Desktop. These may seem like irrelevant details, but this will help us interpret the diagnostic that we may ask from you.

It seems to be 4. The screen stays black while the printer is attempting the print. Incidently CW seems to need the external display option set to extend which at some point it projects the images to the second display. I suspect this is the same with Photonic?

I am refering to what windows should do when it detects the second monitor Set display 1, display 2, or extend. I just want to be clear that I am at the very least setting it properly in windows.

That’s pretty good news. My theory is that your UV lamp doesn’t support exclusive mode very well. Exclusive mode is a hardware based accelerated mode that allows the full screen to be taken over by a device, but Creation Workshop doesn’t use it.

I’ll release a version that allows the user to disable exclusive mode as an advanced option in your printer config. For now, let’s try to put my theory to the test a bit. Setup the display on your printer to “Simulated Display”. This will create a window(labeled “Printer Simulation” and a Java coffee cup) on your main desktop that you can drag over into your second display(UV monitor). If it shows up just fine, then this is going to be a pretty easy fix…

Thanks for your patience.

Tested, and the Java windows shows up on my main display which can then be dragged offscreen to the LED light engine. At this point, the light engine will display the background windows desktop, and part of the dragged Java window.

When I enable the grid, the LED light engine will project a flat bright image without gridlines. When I select show blank, the flat image is lowered in intensity.

During print attempts, the LED light engine stays blank at lowered intensity.

By “part of the dragged Java window”, I assume you mean the part that you dragged over to the second display?

What is meant by a “flat bright image”? What do you mean by flat and what image is being projected?

When you say the image is “lowered in intensity” what image are you talking about?

When you drag the print simulation window back over to the main side, does everything work as you might expect? Calibration shows properly, Grid shows properly and print images show properly when a print is attempted?

Yes, the part that was dragged.

“What is meant by a “flat bright image”? What do you mean by flat and what image is being projected?”

Flat Rectangle meaning just the blank shape of the LED projection 1280X800.
No actual image is ever projected. I state Flat Rectangle as an indicator that the LED engine is actually on.

When I attempt to project a calibration grid, the flat area becomes more intense, but no sliced image or calibration grid is projected.

“When you say the image is “lowered in intensity” what image are you talking about?”

The projected area 1280 X 800 dims when I click to show blank.

“When you drag the print simulation window back over to the main side, does everything work as you might expect?”

Yes, however nothing from Photonic will display i.e. no calibration grid image, no sliced CW image on the LED engine. Only the windows desktop etc. If I happen to switch to display 0 in Photonic, then the calibration grid will appear on the main screen. With display 1 selected, it is only an empty area 1280X800 which will increase with intensity when calibration grid is selected, and decrease in intensity when show blank is selected.

I’ve opened a conversation with keynote photonics. They would like several details about your installation to help troubleshoot this problem. If you don’t mind sharing your email, I’d like to get a discussion with the three of this to hash this out.

For some context, keynote photonics needs a bit more information from you. Here is what they wrote:

I don’t have enough information to know if this is a PEM-type projector with mated Beaglebone or a standard single- or three-color LC4500 or even one of our electronics kits mated up to the customer’s own optics and it’s going to be hard to troubleshoot problems without that to start with. Assuming it’s a standard projector and the customer hasn’t reconfigured it then it should power up showing a splash screen. Is that happening? If so then the projector electronics and optics are working. Next is to determine if it’s getting a usable signal into the HDMI port. The customer will have gotten an account login to download software from Keynote’s website including the GUI which can be used to read what the DMD controller thinks are the incoming video signal characteristics. Here’s an example:

Can you get this information?

Certainly if there is a question about whether or not the LC4500 projector is working properly the customer can feel free to contact me directly with questions. Most likely I or one of my colleagues has already talked with them at some point.

Hi Wes,

I appreciate your efforts. I do not have the light engine by that particular company. They are only 1 of many who use the TI standard.

Mine in particular is from lida optics:
https://lida-oe.en.alibaba.com/product/60328613274-220045352/DLP_Projector_light_Engine_UV_405nm_for_3D_printer_SM7_405.html

Here you have Wintech:
http://www.wintechdigital.com/index.php?route=product/product&product_id=53

And also DataTree:
https://datatree3d.com/uvlightengines/

For now, I am back to CW, but I will keep an eye on this software as it is promising!

Sounds good, let me know if you’d like to start a conversation with your projector manufacturer, it seems they would be very willing to help troubleshoot your issue.

It seems like I might be able to get this going with the right calibration. Is there any documentation that details how to calibrate a non-standard lightsource?

Anything with an explaination of pixel density etc? I know CW kind of calculates this for you.