Problems with start.sh on Raspi with Stretch Light


#1

I’ve been trying to get photonic3d manually installed on a Raspi with Stretch Light. I’ve moved the photonic .zipfile and the start.sh over to the pi, and run the start.sh following the instructions on here. However the start.sh was dated and had a variety of problems. I had to change the java install links first of all, and had to change —force yes to and allow command. After running start.sh. The web app showed up on the pi’s ip but whenever I tried to do anything I had an internal server error pop up. Upon looking at the log files I noticed certain java.awt libraries were missing and found which ones with -ldd and installed them. Now my log files no longer contain errors but I still get internal error on server.

I think this could be because of a problem when running my start.sh. I still get a couple of errors when doing that. These all seem to be involving xorg. “xhost can not find display :0.0” and a similar error with the xsets. In addition I get an xinit error and then it says the server shut down successfully. I’ve tried a variety of things and am lost at this point.


#2

A picture of what exactly outputs when I run start.sh


#3

error
and a picture of my log.err