PrintFlow3D download


#103

image


#104

Wondering if it comes in the devel package. Let me try something.


#105

Whatever distro of Linux you are running now, it didn’t start with our image. Our stock image has those libs already installed. Just did a fresh test…


#106

But that is just it, it IS from the downloads page (Rasp Pi system Image). I use the pi image, your dev install steps and then kweb install… Should I use the Vendor Specific Image?


#107

Erasing SD card and going fresh… Will try again…


#108

I just followed your instructions exactly and it’s all right there.


#109

First boot now. Give me a few to get everything loaded


#110

loaded RPI image
update/upgrade
dev install
kweb install
update/upgrade
sudo nano /opt/cwh/config.properties
uncomment 2 lines
sudo reboot

LogBundle (1).zip (25.5 KB)


#111

Well this is just crazy, I just performed your steps on a clean image and it’s right there. Only thing I didn’t do was the update/upgrade… I guess I can try another fresh download from your link and install tonight. Until then, what you can do is run:
find / -name libbcm_host.so 2> /dev/null

…after each step to determine what is wiping out that directory structure. Once that comes up blank, that was the step that wiped out the bcm libraries.


#112

Wrote RPI Image from your link: http://d359hvxwrop0le.cloudfront.net/photonic-image.zip
Added SSH file to file system
find / -name libbcm_host.so 2> /dev/null
results: /opt/vc/lib/libbcm_host.so
sudo apt-get update
find / -name libbcm_host.so 2> /dev/null
results: /opt/vc/lib/libbcm_host.so
sudo apt-get upgrade
find / -name libbcm_host.so 2> /dev/null
results: /opt/vc/lib/libbcm_host.so
sudo wget -O start.sh https://github.com/WesGilster/Photonic3D/raw/master/host/bin/start.sh
sudo chmod 777 start.sh
sudo ./start.sh WesGilster/Photonic3D
find / -name libbcm_host.so 2> /dev/null
results: /opt/vc/lib/libbcm_host.so
wget http://steinerdatenbank.de/software/kweb-1.6.8.tar.gz
tar -xzf kweb-1.6.8.tar.gz
cd kweb-1.6.8
./debinstall
find / -name libbcm_host.so 2> /dev/null
results: /opt/vc/lib/libbcm_host.so
sudo vi /opt/cwh/config.properties
uncomment 2 lines
sudo reboot
find / -name libbcm_host.so 2> /dev/null
results: /opt/vc/lib/libbcm_host.so


#113

Strangely, after I execute all of those steps, I’m left without a working XWindows environment. However, the bcm_host libraries are always available…


#114

I also notice you have both displays available.


#115

Yeah, that’s what I was intending to show, that the Raspberry Pi displays are available, I didn’t however expect XWindows to die in the process…

Two things are going on here:

  1. The apt-get upgrade breaks XWindows and breaks the kweb install.(Although it did not break the Raspberry Pi displays install) which implies:
  2. We both are starting with different images, or you’re running a command that I’m not aware of.

#116

What about if we just do update/upgrade in the beginning of fresh image and not after modifications or does your dependencies rely on something that is in the latest updates?


#117

I never suggested doing the upgrade/update in the first place. I was attempting to follow your instructions to reproduce your problem.


#118

I understand. I was just wondering if that would work. I was always told to update/upgrade after every “install” so therefore I never tried it… Obviously there is something that is getting broken in the process


#119

Ok. This thread really needs a level set. All you need is to have the bcm_host libraries right?

Then do this:
apt-get remove libraspberrypi-dev
apt-get install libraspberrypi-dev


#120

Ok, well I thank you for your help to this point. Since it seems as though your are just as frustrated as myself, I will wait till the next version is released and hope that works since this one is not. I do not understand how we are getting different outcomes when we do the same procedures. I just did EXACTLY as you have listed and I do not have the display options and my screen is 1/2 showing on the 7" pi touch screen.


#121

Have you tried the bcm uninstall and install? That will get your Raspberry Pi Force TV back.


#122

Yes, nothing changed.
¯_(ツ)_/¯