PrintFlow3D download


#41

Yeah, at this point you’ve found a pretty good work around to matchbox WM. You might find some quirky bits like the mouse cursor that you’ll want to hide with unclutter.

Your last step is to add your kweb start command at the bottom of /cwh/opt/start.sh

That will should tide you over until the next upgrade comes from Photonic that will do all of this by default. Nice job for figuring this out on your own!


#42

And that start command would be? LOL.


#43

I assume you’ve been using it this whole time:
kweb -kl http://localhost:9091


#44

No, I am in desktop, click on kweb and enter the address. I tried to boot to CLI but it keeps taking me to desktop. I am using Newest Rasbian Stretch.


#45

That’s fine, Linux doesn’t care whether you start it from the command line vs. the desktop. What it does care about is that the user has access to the Xwindows session. There are a thousand ways to do this, but they all revolve around adding kweb to some sort of autostart file. If you know the user that is running the session you could put the the kweb command in the .xinitrc file located in that user’s home directory.

I suggested putting it in Photonic3d’s start.sh file because we’ve done the work to add Photonic3d as a Linux service which also means it has access to Xwindows.

First check to make sure the kweb command is working to your satisfaction by opening a terminal from your desktop. You should find the terminal either on the desktop or inside one of the GUI’s start menus.

Once you open the terminal just type the kweb start command above. If it starts to your satisfaction, you can add it to the end of your start.sh file.

You can add it to the file using a command called nano, or if you are brave you can try the following:
type: vi /opt/cwh/start.sh
type: shift+g
type: i
type: kweb -kl http://localhost:9091
ESC key
type: :x[enter key]


#46

This is what it looks like by typing kweb -kl http://localhost:9091

And these are the setting that are defaulted.


As you can see, it is not full screen and the image does not display properly. I have to manually choose full zoom, JavaScript, cookies, and uncheck the rest. I then have to go to kweb application tab and click on toggle full screen so it shows like I have displayed previously.

I greatly appreciate the help I have received form you guys!


#47

Darn that’s not helpful. Let’s try something better:
kweb -KZ -H http://localhost:9091


#48

I forgot to enable javascript. This should do it…
kweb -KZJ -H http://localhost:9091


#49

Here is what I’m using for the command line options:
http://steinerdatenbank.de/software/kweb_manual.pdf


#50

You’ll need cookies turned on for authentication if you’ve enabled basic authentication in Photonic3D:
kweb -KZJE -H http://localhost:9091


#51

Tried the last one (kweb KZJE -H http://localhost:9091) and got this.


#52

kweb -KZJE http://localhost:9091. Just need to get rid of the scroll bar and golden on dashboard. I think I did that before by zooming out by 1 click?


#53

Too easy. Now get it into your start.sh file.

After that you need to start learning HTML and Angular! :slight_smile:


#54

How to get rid of the slider in dashboard? I mentioned it above but you replied before I finished my edit :wink:


#55

I used this
You can add it to the file using a command called nano, or if you are brave you can try the following:
type: vi /opt/cwh/start.sh
type: shift+g
type: i
type: kweb -KZJE http://localhost:9091
ESC key
type: :x[enter key]

But I am using it by Putty SSH and the same keystrokes do not apply :wink:


#56

Same keystrokes apply in all versions of Unix vi from mainframes, AIX all the way to linux. That’s why it’s still so popular. Where did you get hung up?


#57

You may need to do:
sudo vi /opt/cwh/start.sh


#58

Like this? Exit and save?
image


#59

nope I told you wrong.
Should be:

type: vi /opt/cwh/start.sh
type: shift+g
type: arrow right to the end of line
type: a [enter key]
type: kweb -KZJE http://localhost:9091
ESC key
type: :x[enter key]


#60

to get out without saving:
type: [ESC key]
type: :q!