PrintFlow3D download


#21

The reason I ask is because when you are doing above mentioned steps, when you type ./debinstall, you are still in the kweb dir from the previous (cd kweb-1.6.8). I have tried multiple things and I can not get it properly. I can get the web page on a different computer on network to see web page but on the pi 7" setup, just CLI. Also on the web page, D7 does not connect but that may be where you were saying it needs to be worked out.

I have tried:
photonic-image
wget http://steinerdatenbank.de/software/kweb-1.6.8.tar.gz
tar -xzf kweb-1.6.8.tar.gz
cd kweb-1.6.8
./debinstall
and just goes to CLI login when finished

Photocentric-photonic3d results same as above

Maybe I am missing something?


#22

Hi!

I’m one of the persons which made 7" touchscreen interfaces for Photonic (including printflow). What Wes was trying to tell you (correct me if I’m wrong) is that the touchscreen interface is nothing more than a browser starting fullscreen on the touchscreen.

In the case of Photocentric we used the browser kweb since it doesn’t use too much resources. (Altough it still uses to many resources for photonic to still slice .stl files). When kweb is started it connects to localhost:9091/printflow

The printflow folder is an additional folder with webpages for the touchscreen, the vanilla version of Photonic currently hasn’t got these included.

But in the case of Photonic3D it has more dependencies than the normal vanilla Photonic. And the company that helpt me with it has hardcoded a lot for photocentrics specific machines (annoyingly much). So in order to get everything to work you still will need to tweak quite some things which might get hard without developer experiences. We do have a set-up script for this specific image but it won’t work out of the box with non photocentric printers.

I’m currently working on supporting other single board computers and together with Wes I’m looking into a skin selection option for photonic which also is able to handle touchscreen out of the box :slight_smile:

If you want the printflow3d setup than my advice for now would be to just be patient. Unless your eager to learn some programming and linux ofcourse!


#23

I am always open to learn things :wink: I see that the pi and touch screen option is becoming more popular with the resin printers and I have a few and would like to implement it to them to give them a nice look.


#24

When you say you can’t get it properly, what do you mean? My guess is that it installed just fine. That was just step 1. Now it’s time to start your newly installed browser.

You should just type:
kweb

…and then to test it, browse to http://localhost:9091


#25

so from the CLI, type kweb and it brings up a browser?


#26

That’s right. One step at a time. We are just verifying your browser is operational.

Imagine you were in Windows at a command line prompt and you typed:
c:\Program Files (x86)\Google\Chrome\Application\chrome.exe

Same kinda thing…


#27

Tried it and got an error
pi@photonic3d:~$ kweb

(kweb:1169): Gtk-WARNING **; cannot open display:


#28

Did you mention before that your touch screen was still at a login prompt?


#29

Thought that’s whats considered CLI? Yes, it loads and takes me to login, I login and then type kweb and get that error. I guess it is supposed to auto login and start kweb?


#30

type:
echo $DISPLAY

and let us know what it says. If it says anything other than :0.0 then you probably need to define it like this:
export DISPLAY=:0.0

What this is doing is telling which screen that kweb should start in.


#31

I typed it and the first time nothing then I typed the export and then I got the :0.0. I then typed kweb and got:
(kweb:1562): Gtk–WARNING **: cannot open display: :0.0


#32

I’m assuming you logged in as a user that didn’t start xwindows. Run this:
xhost +localhost

to give that user access, and then try to run kweb again. When we add this feature to Photonic, it won’t happen because Photonic starts xwindows.


#33

xhost: unable to open display “:0.0”. kweb has same warning as before. Which img should I use? Any other place to dl beside the DL page? Can you by any chance put up a link to one that you know works from a google drive or something? LOL


#34

I finally got somewhere. I installed new Rasbian Stretch w/Desktop and install everything else. So it boots to desktop and if I go to MKB, I can go to localhost and the headers will show but nothing else. If I go to my win computer and go to ip:9091 I see Photonic 3D and have to add user. I do and then that user does not seem to show. I have also setup the printer (D7) from json list and made a few settings and I can control my printer from win comp. That is as far as I have gotten.


#35

Well, silly me, had to enable java from dropdown on kweb. So far all is showing and I can control printer. Now just need to have it autostart to kweb in full screen and not current desktop.


#36

Nice work man!

Woah, hold on, you have to add a user? What version of Photonic are you running? I see that the users tab is also visible, that must be a really old version where I accidentally enabled the user management…

To not show the borders/buttons/address bar you need to run in Kiosk mode:
http://steinerdatenbank.de/software/kweb_manual.pdf

Never done this, but you just specify the URL and tell it to start in Kiosk mode like this maybe:
kweb -kl http://localhost:9091

If that works, try to move onto the next step. You mentioned you downloaded printFlow to your Raspberry Pi right? Now let’s see what you can do with these instructions:
https://wiki.photonic3d.com/doku.php?id=supporting_new_skins

Let us know how we can improve the documentation if it isn’t sufficient…

We are in the process of evaluating other browsers for the touch screen, but kweb is high on the list right now.

It’s actually very weird that you had to enable Java, we don’t use Java on the client at all. Did you mean you had to enable Javascript?


#37

Yes, Javascript, sorry. Alt+k puts it into kiosk mode and gets rid of the kweb interface but the desktop header still shows.


#38

I have no clue about the skins and how to make them and what is used to put them onto the pi. I also want to +/- some things from the GUI on the pi but don’t know what software to use. Is there something specific to use for a windows comp and then transfer it to pi? Like I said, I have no clue how to code or even what the hell these lines mean that I am entering (well some I understand).


#39

I see, so you want to take this a couple of steps further. You are doing just fine, but you may need to take one step backward in order to get rid of the title bars and stuff. You’ll probably want start using the matchbox window manager like the following:
matchbox-window-manager -use_titlebar no


#40

I have gone into kweb settings and clicked toggle fullscreen under application and that took away the desktop bar and then I Alt+k on keyboard and went full screen. Do I have to dl matchbox window manager? I do not see it in my menus. I just would like all this to auto start and load to P3D dashboard… LOL