Printable files


#1

Dear Wes,

Can I change the directory of the Printable Files to be the USB rather than the current directory which is /root/uploaddir ?


like I need to read the stl files from the USB directly not from the directory of the uploaded files. is it possible ?

thanks in advance, we appreciate your help


#2

You can specify any upload directory that you’d like, but Photonic3D already monitors for new printables that show up on the USB drive if this is set in the config.properties:
feature.org.area515.resinprinter.usbimport.USBUploader=true


#3

Thanks Wes, this feature is already true in the config.properties but didn’t read from the usb directly, I would appreciate your help if you declare how to specify a directory .

Thanks


#4

The USB uploader has been around for a while, so if it isn’t working, it’s likely your usb drive isn’t automounting. If your using Windows, Photonic3D finds the new drives every time. On Linux you may have some issues if your USB automounted drives are named something other than “media”, or “storage”.

I would definitely not suggest changing your upload directory to a location that can unmount at any moment.However, if your willing to see Photonic behave poorly when it can’t find directories, the property you are looking for is:
uploaddir=[USBDrive]

If your interested in seeing why the USB uploader isn’t working for you, then you can add ‘usb’ to the following line in your log4j2.properties file:
loggers=usb,hex,serial,printer,media,cleanupCWS,cleanupZip,printerDisplay,dispManX

This will give your logs much more information to determine why the USBLoader isn’t working for you.


#5

Dear Wes, we are really appreciate your efforts here,
where to add uploaddir=[USBDrive], in which file.??

and also I have added usb to loggers but there is nothing related to usb in the cwh.log file. If i’m looking to the true file.

regards


#6

You’ll need to add that into the config.properties file and to be clear, [USBDrive] needs to be the actual directory.

You’ll need to restart Photonic3D after you add usb to the log42j.properties file.


#7

In the development version, I’ve added another setting on the USBUploader feature to allow you to specify all of the folders you would like uploaded like this:
featureSettings.org.area515.resinprinter.usbimport.USBUploader={"configuredRoots":["/media", "/storage"]}

This will automatically upload from media and storage folders. Or you can configure it to any other folders you’d like.


#8

Dear Wes,
you have no idea how much we are thankful for you we really appreciate your efforts.
I will try these settings, thanks.

Regards


#9

Dear Wes,
I have downloaded the development version, but the cwh did not read the stl files of the USB.
my USB directory is /media/root/3DPRINTER should I change some thing in this feature :
featureSettings.org.area515.resinprinter.usbimport.USBUploader={“configuredRoots”:["/media", “/storage”]}

or just keep it as it is ?

I have another question also, in the wifi setup, there is no available wifi network in the list (access point) I have raspberry pi 3, should I have dongle ?


#10

there is also a problem with this command uploaddir=/media/root/3DPRINTER
the problem is when you reboot the raspberry it will check for this directory /media/root/3DPRINTER and it will not find it (because the usb is not pulg in ) so it will create a folder name 3DPRINTER so after you plug in the usb it will not read it. but if you reboot the raspberry while the usb is plug in then there is no problem it will read from the usb. but we can’t keep the usb plug in always to solve this problem.

thanks Wes for your effort


#11

I would not mess around with the uploaddir any longer. You will have no end to your troubles. On the other hand, the USBUploader should do everything you are looking for. If it’s not working, make sure that the logging is turned on, and perform a diagnostic download and post here.

If you find that the Raspberry Pi 3 wifi is sufficient, then use it. If you decide to look for a wifi dongle, be aware that you’ll need to disable the Raspberry pi’s wifi since you will start getting duplicate SSID scan results.


#12

Dear Wes,

I know I annoyed you, and really thankful for your replays.
All thing are working properly, just reading from the usb is not working and there is no access point in the wifi settings.

how I can be sure about the “logging is turned on” in which file i can find.??
btw I’m working in localhost using kweb browser.


#13

No worries at all. Here are a few things you need to do though.

  1. Clearly think through any comments related to your time investment.
  2. Describe your problem and all related information required to replicate your problem.
  3. If we ask for a diagnostic, then you need to post it. It’s really not a suggestion.

I’m more than certain both features you are speaking about work just fine. I’ve used them both in the last week. In fact, it’s a bit frustrating to find Photonic3D keeps pulling all of the files from the SD cards that happen to insert into my laptop. Also, if wifi isn’t working on your Raspberry Pi, Photonic3D won’t fix that. Photonic3D simply allows you to browse from the existing set of wifi APs and associate itself with that access point.

To determine if logging is turned on, you should see “MasterRoots” and “Unplugged drives” every 3 seconds in the logs. If you don’t want to check yourself, just upload the diagnostic to this post and I’ll check the logs for you. All you have to do is click the download button that is located on every page of Photonic3D.

If your interested in seeing if your wifi is working, you can do what Photonic3D does to get APs. Just run this on a command line:
wpa_cli
scan
scan_results
quit


#14

Dear wes,

the wifi in the raspberry is working properly, but the list of the access point shows no access points.


#15

It doesn’t help to say: “the wifi in the raspberry is working properly”. What would help would be to show the output from the following:
wpa_cli
scan
scan_results
quit

That’s all that Photonic3D is doing to get your ap scan results. The commands are simple to run, and if they aren’t working, then it’s unlikely your wifi is operational.

For example, your wifi isn’t working if it says this:

wpa_cli v2.4
Copyright (c) 2004-2015, Jouni Malinen <j@w1.fi> and contributors

This software may be distributed under the terms of the BSD license.
See README for more details.



Interactive mode

Could not connect to wpa_supplicant: (nil) - re-trying

On the other hand, if it says this something like this, it’s probably ok:

wpa_cli v2.3
Copyright (c) 2004-2014, Jouni Malinen <j@w1.fi> and contributors

This software may be distributed under the terms of the BSD license.
See README for more details.


Selected interface 'wlan0'

Interactive mode

> scan
OK
<3>CTRL-EVENT-SCAN-STARTED
<3>CTRL-EVENT-SCAN-RESULTS
> scan_results
bssid / frequency / signal level / flags / ssid
22:44:44:66:44:22       2412    -71     [WPA-PSK-CCMP+TKIP][WPA2-PSK-CCMP+TKIP][WPS][ESS]       HomeNetwork8888
aa:44:dd:55:66:cc       2412    -61     [WPA2-PSK-CCMP][WPS][ESS][P2P]  \x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00
>quit

#16

root@raspberrypi:# wpa_cli
wpa_cli v2.4
Copyright © 2004-2015, Jouni Malinen j@w1.fi and contributors

This software may be distributed under the terms of the BSD license.
See README for more details.

Selected interface ‘p2p-dev-wlan0’

Interactive mode

scan
OK
scan_results
bssid / frequency / signal level / flags / ssid
c4:e9:84:9b:c5:d0 2437 -62 [WPS][ESS] Almira_Teknoloji
d4:6e:0e:a6:c3:40 2412 -84 [WPA2-PSK-CCMP][WPS][ESS] Yuntes \xc4\xb0stanbul


#17

That’s much more informative, thanks. Could you run this as well:

ifconfig | grep Link | awk '{print $1}'

…and post the contents of course


#18

Dear Wes, when I have changed to the raspberry to Jessie then the network problem have been solved now I can see the access points clearly. but when I used stretch raspian I couldn’t see the access points.
Thanks, let we see how is it going.


#19

It’s great that you fixed it yourself, but if you just take the troubleshooting steps above we could have solved it. What specific image were you using?


#20

I just picked the latest version of Raspbian stretch and the problem seems to be with:
ifconfig | grep Link | awk '{print $1}'

I fixed it in the latest dev version. Tested on Kali, Raspbian Stretch, Raspbian Jessie and Ubuntu.