3DFacture Draken 3Dprinter


#1

From the early days of photonic3D(Back than known as Creation Workshop Host) I’ve been using this software to control my Draken 3Dprinter.

The software is great for this printer. You can control all the functions and you can easily manually control the printer, from within the software you can even turn on and off the project very easily and you can monitor your print at all times! It just works great for use with this DLP printer.


#2

Hi Robin,

I have the Draken 3DFracture printer too, can you teach me how to use Photonic3D.

I already have the raspberry Pi installed with CWH, connected to network and the 3D printer. The projector is connected to VGA port via a PC running Window XP.


#3

Hi @terrencelau ,

Welcome on this forum and hopefully welcome in the community! We would love you to work with us.

Firstly I haven’t touched my draken in ages, the Vats broke down (all 3 of them) within 1-2L, 3DFacture would send new ones but haven’t heard since. So I haven’t tested lately to get this printer working with photonic3d (old CWH).

However I will do my best to get you printing and testing with this software! So where are you stuck? You should power up the pi, connect HDMI and connect the internet to the pi (with wifi(dongle)/ethernet).

Have you tried anything yet? If so please let me know where you get stuck, if your somewhere close to the EU timezone and you really won’t get it to work we can set up a teamviewer/skype thingy no worries!

Do you have by any chance any programmer experience?

Kind regards,

Robin


#4

Hi Robin,

Yes, I have my Pi powered up and connect to a router via ethernet cable. My 3D printer is connect to the Pi’s USB.

From my PC (running XP0, I can access the printer via my browser (Chrome). I can control the 3D printer (use the Photonic3D UI) Z-axle up & down. So I suppose my setup is correct.

When I upload a printable file (STL type) and click print; the printjob show the model is in the slicing process. After waiting the slicing process finishing. However no printing come out !

Terrence


#5

Do you see any output from the screen? like do you see the slices projected from the projector?


#6

Yes, I do see the slices on the output screenbox but do not see slices on the projector.

My projector is set as 2nd monitor and is connect to my PC via VGA cable. Using the remote control to turn it on since I don’t have COM port to connect to the projector.

Terrence


#7

Ahhh there we have the problem, I thought I understood you wrong ;)! Photonic3D is meant as a replacement for your pc. It makes your printer truly stand alone! So you should connect your printer to the raspberry pi instead of your pc ;)! That should help :slight_smile: !


#8

So as in printer, also your projector! We don’t use the computer other than GUI ;)!


#9

My 3D printer is already connect to the Pi’s USB.

How to connect my projector to the Pi and if I need any setup on the projector?

Terrence


#10

Just use the HDMI port of the pi. You could connect serial(COM) to if desired (you will need an usb to serial converter but than the software can turn on/off the projector etc). But just connecting HDMI to the pi is enough to make it work ;)!


#11

Did you succeed to get it working? Or having problems? We would love to hear from you!

Robin


#12

I had plugged the projector to the Pi’s HDMI port and restart the Pi again.

But unfortunately printing is still not succeeded. No slicing image sends to the projector. Only the brandname of the projector is shown.

On the GUI, I can see printer status is "printing’ but still no action or movement on the Z-axle.

I try to detect the projector using the DLP control but it comes out “Projector;s model could not be detected”.

For the whole process, I did not pour ink inside the tank.


#13

Hi!,

I’m sorry to hear it’s still not working. Have you configured the screen right in the printer set up? (most likely 0,0) is the channel correct on the projecter? All cables tight? What projector do you have by the way?

Robin


#14

Yes, it is 0,0. i have checked all my connections without problem. My projector is Acer.


#15

Finally, I find the issues.

First, I had not select the source output of my projector.
Second, It seems the GUI cannot print STL file directly. I test the setup with a CWS file, the machine works fine.

Now, another question, how can I change a STL file to CWS file?


#16

Great to hear! We should by the way be able to print STL files. You even indicated the slices show up in the GUI correct? I will make some new clips soon to explain all functions and I got an old one here : https://www.youtube.com/watch?v=ng1Sj2ktWhU It’s pretty old and the whole install progress. But it might help you till I make my new ones ;)!

Robin


#17

For the STL slicing not showing can you make a new thread in the bug section of this forum? Thank you! (Which can be found here : http://forum.photonic3d.com/c/help)

Robin


#18

Hello Robin, I hope you can help me to control my Draken with the photonic3d host. I’ve installed it in my Pi, but got stuck with the initial screen. I tried to add a new printer and configure it, but it got me anywhere. What should I do?


#19

Hi eduardobindi,

I haven’t touched my Draken in a while but I will try to help you. Can you tell me what projector you are using and reproduce this, after reproducing press download and upload the downloaded zip here so we can take a look.

Thank you very much!

Robin


#20

This usually happens when you haven’t properly setup X-Windows. Could you describe how you setup your Photonic installation? This will let us know a bit about which step may have been skipped.

	try {
		ge = GraphicsEnvironment.getLocalGraphicsEnvironment();
	} catch (NoClassDefFoundError | HeadlessException | AWTError error) {
		throw new InappropriateDeviceException("It doesn't look like your graphics environment is properly setup", error);
	}